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PSpice 

 

O pacote Microsim é um software de simulação desenvolvido  pela Microsim 
Corporation. Ele é composto pelos principais programas:  

.Microsim Schematics: onde é feita a edição do circuito;  

.Microsim PSpice: responsável pela compilação e interpretação;  

.Microsim Probe: visualização gráfica dos resultados obtidos;  

.Microsim Stimulus Editor: edição dos estímulos de entrada 

Basicamente os arquivos são gerenciados pelo Design Manager que é automaticamente 
aberto quando qualquer outro programa é aberto.  

 
 
Simuladores de circuitos são poderosas ferramentas de software que permitem a análise 
de sinais elétricos, sem a necessidade da implementação física dos mesmos. 
Possibilitam uma análise em geral mais rápida, segura e barata do que a montagem 
física do circuito. 
 
Particularmente para o projeto de circuitos integrados, a simulação é uma ferramenta 
fundamental, pois a implementação física do chip é um processo caro e demorado. Um 
circuito integrado só é fisicamente construído quando todas as simulações elétricas do 
circuito mostram o resultado desejado. 
A versão utilizada do PSPICE é de propriedade da CADENCE Design Systems , sendo 
que a versão utilizada neste apostila é a 9.1 (versão estudante) . 
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Aviso e Termo de Responsabilidade 
 

Esta apostila é escrita com autorização de CADENCE Design Systems .  

PSpice é uma marca registrada de CADENCE Design Systems 

Windows é uma marca registrada de Microsoft Corporation 

O autor perante à qualquer pessoa ou sociedade não é responsável com respeito à danos 
ou perdas causadas pelas informações contidas nesta apostila ou pelo uso de disquetes , 
cds ou programas que possam acompanhá-la .  
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1.Desenhando um esquema de um circuito elétrico  
 
Para iniciar devemos ir ao menu de programas e procurar pela pasta PSpice > 
Schematics 
:

 
A seguinte tela se abrirá : 

Copyright  2003 - PSpice – Guia passo-à-passo -      7 



 

 
 
 
Esta tela também é chamada de folha e é nela que iremos desenhar nossos circuitos . 
 
Instruções Gerais : 

- O Microsim PSpice não distingue entre caracteres maiúsculos e minúsculos.  
- O nome de um campo deve começar com uma letra, mas os caracteres que se 

seguem podem ser letras, números ou: "$", "_", "*" ou "%". Nomes podem ter 
131 caracteres.  
- O número de um campo pode ser inteiro ou real. Números inteiros e reais 
podem ser seguidos por um expoente inteiro(7E-6, 2.136e3) ou um fator de 
escala simbólico(7U, 2.136K). Veja a tabela dos fatores de escala:  

Símbolo Forma exponencial 
F  1E-15  
P  1E-12  
N  1E-9  
U  1E-6  
M  1E-3  
K  1E3  

MEG  1E6  
G  1E9  
T  1E12  
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- Letras imediatamente seguindo um número que não são fatores de escala são 
ignoradas, isso vale também para letras imediatamente seguindo um fator de escala. Por 
exemplo, 10, 10V, 10Hz e 10A representam o mesmo número. O mesmo pode ser dito 
para 2.5M, 2.5MA, 2.5Msec e 2.5MOhms.  

Vamos agora inserir os componentes que iremos utilizar : 
 

1) Clique no menu Draw > Get New Part 
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A seguinte janela aparecerá: 

 

Caso você queira selecionar os componentes e vê-los, clique em Advanced.  
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A seguinte janela se abrirá:  

 

Para selecionar os componentes pelas bibliotecas, clique em Libraries. A seguinte 
janela aparecerá: 
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Para definir os componentes a serem utilizados siga o exemplo : 
 

 
Em Part Name digite R , você observará a figura de um resistor , a seguir pressione 
o botão PLACE , você agora poderá colocar o componente sobre sua folha apenas 
clicando com o mouse . 
 
Insira agora os outros componentes que usaremos digitando : 
 
- EGND para terra ; 
- VDC para fonte de tensão contínua ; 
 

 
É obrigatório a presença de um nó "zero", que será o nó de 

referência ( usualmente o nó de "terra" do circuito) , ao qual serão 
referenciadas todas as tensões calculadas, o "terra" deve sempre ser 

fixado no circuito . 
 

 
À seguir pressione o botão CLOSE para sair . 
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Você deverá ter a seguinte tela agora : 
 

 
 
Para melhor visualização utilize os botões de Zoom . 
 
Vamos agora desenhar as linhas (wires) que ligarão nosso circuito , para isso clique 
no botão Desenhar Linhas (Draw Wire) , o cursor agora passa a ter a forma de um 
lápis permitindo que você desenhe as linhas clicando com o mouse no ponto inicial 
e final da ligação , para sair desta função basta pressionar o lado direito de seu 
mouse . 
 
Você deve ter agora o seguinte circuito : 
 

 
CUIDADO PARA NÃO DESENHAR UMA LINHA SOBRE O 

COMPONENTE  O PSPICE ENTENDERÁ COMO UM CURTO E 
IGNORARÁ O COMPONENTE 
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Para imprimir o esquema ou gráfico , selecione o menu File > Print  
 
Para rotacionar os componentes , selecione o componente e pressione Control+R , 
ou menu Edit > Rotate 
 
Vamos agora explicitar os valores dos componentes : 
 
1) Clique 2 vezes sobre o texto 0V uma caixa de diálogo se abrirá permitindo que 

você altere o valor da fonte de tensão DC  , mude o valor para 10 V e pressione 
OK para confirmar . 

 

 
 
 
2) Vamos agora definir o valor do resistor , clique 2 vezes sobre o texto 1k (valor 

padrão) uma caixa de diálogo se abrirá permitindo que você altere o valor da 
resistência , mude o valor para 100 Ohms e pressione OK para confirmar . 

Uma outra maneira de ajustar os valores 
dos componentes é clicando duas vezes sobre estes.  

Por exemplo, ao clicarmos duas vezes sobre um resistor, a seguinte janela aparece:  
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Selecione cada característica do componente e faça a alteração.Ao alterar os valores 
clique em Save Attr. Ao término, clique em OK.  

 
Para salvar o esquema desenhado vá ao menu Arquivo (Files) , Salvar Como (Save 
As) : 
 

 
 

Monte agora o seguinte circuito : 
 

 
 
Utilize os componentes VDC , R , EGND e BUBBLE . 
 
clique 2 vezes sobre o componente Bubble , uma caixa de diálogo se abrirá 
permitindo que você altere o seu texto , ele servirá como um marco de referência 
para medirmos o valor da tensão nos resistores ( todas as tensões são sempre 
medidas tendo como referência o terminal terra ) . 
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1.1 Simulando o circuito 
 
Vamos rodar agora a simulação do programa afim de sabermos qual o valor das 
tensões nas referências (bubbles) , pressione o botão Simulate . 
 

 
 

A seguinte tela se abrirá : 
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Pressione o botão ao lado : 
 

 
 
Aparecerá então o arquivo contendo os valores das tensões simuladas do circuito : 
 
 
**** 08/10/02 02:10:56 *********** Evaluation PSpice (Nov 1999) ************** 
 
 * C:\Meus documentos\Schematic1.sch 
 
 
 ****     CIRCUIT DESCRIPTION 
 
 
****************************************************************************** 
 
* Schematics Version 9.1 - Web Update 1 
* Sat Aug 10 02:04:55 2002 
 
** Analysis setup ** 
.OP  
 
* From [PSPICE NETLIST] section of PSpiceev.ini: 
.lib "nom.lib" 
 
.INC "Schematic1.net" 
 
**** INCLUDING Schematic1.net **** 
* Schematics Netlist * 
 
 
 
V_V1         $N_0001 0 100 
R_R1         $N_0001 VA  1K   
R_R4         VB VA  2K   
R_R5         VB 0  2K   
R_R3         0 VA  4K   
 
**** RESUMING Schematic1.cir **** 
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.INC "Schematic1.als" 
 
 
**** INCLUDING Schematic1.als **** 
* Schematics Aliases * 
 
.ALIASES 
V_V1            V1(+=$N_0001 -=0 ) 
R_R1            R1(1=$N_0001 2=VA ) 
R_R4            R4(1=VB 2=VA ) 
R_R5            R5(1=VB 2=0 ) 
R_R3            R3(1=0 2=VA ) 
_    _(VA=VA) 
_    _(VB=VB) 
.ENDALIASES 
 
**** RESUMING Schematic1.cir **** 
.probe 
 
.END 
 
**** 08/10/02 02:10:56 *********** Evaluation PSpice (Nov 1999) ************** 
 
 * C:\Meus documentos\Schematic1.sch 
 
 
 ****     SMALL SIGNAL BIAS SOLUTION       TEMPERATURE =   27.000 DEG C 
 
 
****************************************************************************** 
 
 NODE   VOLTAGE     NODE   VOLTAGE     NODE   VOLTAGE     NODE   VOLTAGE 
 
 
(   VA)   66.6670  (   VB)   33.3330  ($N_0001)  100.0000                    
 
 
    VOLTAGE SOURCE CURRENTS 
    NAME         CURRENT 
 
    V_V1        -3.333E-02 
 
    TOTAL POWER DISSIPATION   3.33E+00  WATTS 
 
**** 08/10/02 02:10:56 *********** Evaluation PSpice (Nov 1999) ************** 
 
 * C:\Meus documentos\Schematic1.sch 
 
 
 ****     OPERATING POINT INFORMATION      TEMPERATURE =   27.000 DEG C 
 
 
****************************************************************************** 
 
 
 
          JOB CONCLUDED 
 
          TOTAL JOB TIME             .01 
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1.2 EXERCÍCIOS 
 

1) Determine agora a tensão VA , VB e VC do circuito à seguir : 
(Gerador de Corrente -> IDC ) 

 
VA (V)  
VB (V)  
VC (V)  

 
2) Determine agora a tensão VA , VB e VC do circuito à seguir : 

 
 

VA (V)  
VB (V)  
VC (V)  

 
Uma outra maneira de se ver os resultados é através dos botões V (Tensão) e 
I (Corrente ) : 
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2. DC SWEEP (Variando parâmetros p/ obter a Curva de 
Transferência) 
 

Até agora para simularmos o circuito com diferentes valores , deveríamos mudar o 
valor desejado e rodar novamente quantas vezes fossem as analises desejadas , 
vamos aprender agora como simular o circuito para diferentes valores numa mesma 
simulação. 
 
Vamos desenhar o circuito abaixo : 

 
 
A pergunta é : como varia a tensão Vo quando variamos V1. Vamos abrir o menu 
Analysis > Setup . 
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a seguinte tela se abrirá : 
 

 
 
Vamos pressionar o botão DC Sweep , a caixa de diálogo aparecerá , preencha-a 
conforme o indicado e confirme : 
 

 
 
Acabamos de dizer ao programa para simular a variação de uma fonte de tensão 
(Voltage Source) , indicamos qual fonte sofrerá a variação (Name : V1) , 
escolhemos o tipo de variação (Linear) e definimos os valores inicial , final e o 
incremento da variação . 
 
A seguir feche a tela Analysis Setup , verificando que agora o item DC Sweep está 
selecionado . 
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Vamos rodar agora a simulação do programa afim de sabermos qual o valor da 
tensão em Vo em função de V1 , pressione o botão Simulate . 
 

 
 

A seguinte tela se abrirá : 
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Selecione no Menu Trace > Add Trace 
 

 
 
Selecione a tensão V(Vo) e confirme : 
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Teremos então o gráfico da variação de Vo em função de V1 : 
 

 
 
Para inserir um novo gráfico no mesmo eixo repita o procedimento ( apenas tenha 
cuidado para não colocar gráficos com valores máximos muito distantes ou você 
terá problemas de escala para visualização ) . Você também pode plotar o gráfico de 
funções utilizando as variáveis de tensão e corrente , bastando escrever a expressão 
na tela Add Trace . 
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2.1 EXERCÍCIO 

 
Plote as tensões Va , Vb e Vc quando a fonte DC varia de 1 à 20 V . 
 

 
 

2.2 Curva Característica do Diodo 
 

Componentes : Resistor (R) , Fonte Dc (Vdc) , marcador (Bubble) , Diodo 
(D1N4148) , Terra (EGND) 
 
Vamos variar a fonte Dc de –15 V à 15 V , modo Linear , incremento 0.1  . 
 

 
 

Vamos plotar a corrente I(D1) . 
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Vamos agora definir o eixo X como sendo a tensão Vd . 
 
Entre no menu Plot > Axis Settings  
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Agora pressione o botão Axis Variable ( para definirmos qual variável estará 
representada no eixo x ) : 
 

 
 

Vamos escolher V(Vd) e confimar Ok em seguida até retornarmos a tela do gráfico : 
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2.3 Curva Característica do Diodo Zener 
 

Plote a curva característica do Diodo Zener do circuito abaixo variando V1 de –15 V 
à 15 V  : 
 
Componentes : Fonte de tensão (Vdc) , Resistor  (R) , marcador (Bubble) , Diodo 
Zener , Terra (EGND) 
 

 

Eixo x : V(Vz) 
Eixo y : -I(R1) (para indicar a corrente 

no sentido positivo da tensão de 
referência ) 
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2.4 Circuito com Diodos  
 

Plote a curva correspondente à Vs variando a tensão V1 de –10 V à 20 V : 
 
Componentes : Fonte de tensão (Vdc) , Resistor  (R) , marcador (Bubble) , Diodo , 
Terra (EGND) 
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2.5 Curva característica do Transistor 

 

 

Componentes : Fonte de tensão 
(VSRC) , Fonte de corrente 
(ISRC) , 
Transistor (Q2N222) , Terra 
(EGND) 
 
Monte o circuito ao lado e 
configure o Setup do Analysis 
conforme indicado abaixo ( não se 
esqueça de ativa o Nested Sweep , 
afim de variar a corrente 
simultaneamente com a tensão ) . 
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Quando finalizada a simulação voltaremos ao Probe , para visualizarmos a curva 
basta entrar no Add Trace > e selecionar IC(Q1) , ou seja , corrente de coletor do 
transistor . 
Para desenharmos também a reta de carga , basta acrescentarmos uma nova curva 
Add  Trace > , vamos escrever a expressão da reta de carga (V1_maximo – 
V_V1)/Rc , ou seja , definimos um valor para V1_Maximo e um valor para Rc 
(resistor do coletor) , no exemplo fizemos : (10-V_V1)/25 . 
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3. Teorema da Superposição e Proporcionalidade  

3.1 A função de transferência (Transfer Function) 
 
O comando Transfer Function nos diz qual a relação entre uma tensão de saída e 
uma tensão de entrada , basta ativar a função , definir as variáveis de entrada e saída 
e simular Simulate , a função de transferência estará mostrada no arquivo de saída . 
 

 
 

 
 
A variável de saída deve ser colocada da forma : V(variável_saída) . 
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****     SMALL-SIGNAL CHARACTERISTICS 
 
 
      V(Vs)/V_V1 =  5.000E-01 
 
      INPUT RESISTANCE AT V_V1 =  2.000E+03 
 
      OUTPUT RESISTANCE AT V(Vs) =  5.000E+02 
 
 
          JOB CONCLUDED 
 
          TOTAL JOB TIME             .18 
 
Ou seja , Vs = k1*V1 = 0.5*V1  . 
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EXERCÍCIOS 

 
Vamos aplicar o Teorema da Proporcionalidade e da Superposição afim de descobrir 
quais as relações de V1 , V2 e I1 com a tensão de saída Vs , para isso vamos montar 
o circuito a seguir e determinar as constantes k1 , k2 e k3 aplicando o recurso da 
Função de Transferência ( Transfer Function) . 
 

 
 
Não se esqueça que para respeitar o teorema temos que zerar as outras fontes que 
não estão sendo analisadas . 
 
Vs = k1*V1 + k2*V2 + k3*I1  
 

k1  
k2  
k3  
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3.2 Medindo a resistência equivalente do circuito 
 
Imagine que nos quiséssemos saber qual a resistência equivalente entre dois ptos 
quaisquer de um circuito , para isso basta puxarmos dois “fios” daqueles pontos , 
colocar uma referência (bubble Vs) afim de sabermos o valor da tensão naquele 
ponto e ligarmos um gerador de corrente , aplicamos então o DC Sweep fazendo 
variar a corrente de 0 até um valor qualquer , por exemplo 10 , simulamos e 
plotamos o gráfico de V(Vs)/I_I1 onde Vs é a tensão no bubble e I1 a corrente do 
gerador , ao analisarmos o gráfico , a leitura do valor constante é a leitura do valor 
da resistência equivalente naquele pto do circuito . (Lembre-se que para medirmos 
resistência devemos desligar (zerar) qualquer outra fonte de tensão ou corrente no 
circuito , o método de leitura aqui empregado serve apenas para circuitos com 
resistores , ou seja , cuja impedância não varia com freqüência , para medir a 
resistência de circuitos com indutores e capacitores utilize um gerador de corrente 
alternada com fase zero no lugar do gerador de corrente contínua )  . 
 

 
Para sabermos o valor exato , vá ao menu Trace > Cursor > Display , uma janelinha 
se abrirá , clique com o cursor esquerdo do mouse sobre a curva , você terá agora a 
variação númerica caminhando com o cursor sobre a curva . 
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Requivalente = 970 Ohms 
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4. AC SWEEP (Variando a freqüência ) 
 
A simulação de circuito com diferentes valores de uma grandeza AC é utilizada em 
grande parte para a construção de gráficos de Bode , gráficos de ganhos e fases e 
análise de fasores . O circuito pode ser analisado em uma única freqüência ou em 
mútliplas frequências . Utilizaremos os componentes VAC e IAC nestas simulações 
. 

4.1 Gráfico em função da frequência 
 
Vamos desenhar o circuito abaixo : 
 
 

 
 
Componentes utilizados : VAC , R , L , C , EGND e BUBBLE . 
 

 
 
O valor de ACMAG , ou seja , a magnitude da fonte AC pode ser interpretado como 
um valor RMS ou de Pico , à sua escolha , basta escolher a interpretação desejada e 
todas as outras tensões obtidas serão também interpretadas da mesma maneira . 
 
Para que apareçam no circuito os nomes ACMAG e ACPHASE basta clicarmos em 
Change Display quando inserimos os valores e a seguinte tela apareçera : 
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Basta selecionar a forma que desejamos que seja vista (Valor / Nome / Nome e 
Valor / Nenhum ) , a orientação (Vertical/Horizontal) e confirmar com OK . 
Afim de que os valores desejados de tensão e corrente quando da variação da 
freqüência sejam não somente plotados mas também apareçam no arquivo texto de 
saída é necessário acrescentar um componente chamado PRINT. 
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Ao clicarmos 2 vezes sobre este componente teremos a seguinte caixa de diálogo : 
 

 
 
Ao clicarmos sobre a propriedade analysis poderemos alterar seu valor , definimos 
o valor AC V(2,0) VP(2,0) , que significa que queremos o resultado dos valores 
simulados em AC Sweep da amplitude da tensão V do nó 2 ao terra (0) e da fase da 
tensão do nó 2 ao terra (0) . Se quisermos saber sobre outros nós basta dar um 
comando semelhante na mesma caixa de diálogo ou acrescentar um novo 
componente PRINT . Se quisermos saber os valores em relação à corrente basta no 
lugar de V colocarmos I  , assim teríamos AC I(2,0) IP(2,0) . Podemos fazer as 
combinações de qualquer nó do circuito , não podemos deixar no entanto de 
conectar o componente PRINT ao circuito em qualquer ponto . 
 
Vamos agora ao menu Analysis > Setup  , pressione o botão AC Sweep . 
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A seguinte tela se abrirá : 
 

 
 
Podemos então definir qual a faixa de freqüência faremos a análise das tensões e/ou 
correntes , se quisermos saber sobre uma freqüência específica basta selecionarmos 
para Total Pts : 1 , e Star Freq (freqüência inicial) e End Freq (freqüência final) 
iguais . 
 
Veja o exemplo de como é o texto no arquivo de saída para 3 pontos de 10 Hz à 30 
Hz : 
 
Pressione o botão ao lado para ver o arquivo de simulação : 
 

 
 
****     AC ANALYSIS                      TEMPERATURE =   27.000 DEG C 
 
****************************************************************************** 
 
  FREQ        V(2,0)      VP(2,0)     V(2)         
 
 
   1.000E+01   1.001E-03  -1.339E+02   1.001E-03 
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   2.000E+01   2.525E-04  -1.384E+02   2.525E-04 
   3.000E+01   1.124E-04  -1.400E+02   1.124E-04 
 

EXERCÍCIOS 
 
Determine o valor das tensões nos nós 1 , 2 e 3 na freqüência de 1kHz  e 10 kHz . 
 

 
 

Tensões F= 1kHz F= 10 kHz 
V1   
V2   
V3   

 
Componentes : R , L , C , IDC , VAC , EGND , BUBBLE . 
 
 

4.2 Gráfico da Análise AC na freqüência de 1kHz  à 10 kHz 
 

 
 
 
 Vamos agora ao menu Analysis > Setup  , pressione o botão AC Sweep . 
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A seguinte tela se abrirá : 
 

 
 
Coloque os valores inicial e final das frequências  para a análise , bem como o 
número de pontos à serem analisados entre os valores inicial e final , à seguir clique 
em OK .  
 
Vamos rodar agora a simulação do programa , pressione o botão Simulate . 
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Selecione no Menu Trace > Add Trace 
 

 
 
Selecione a tensão V(Vx) , V(Vy) e V(Vz) e confirme : 
 

 
 
Para marcar algum ponto específico da curva , vá ao menu Trace > Display > 
Cursor  para obter o valor do ponto desejado . Depois vá ao menu Plot > Label > 
Mark e teremos assim o ponto identificado no gráfico : 
 

Copyright  2003 - PSpice – Guia passo-à-passo -      43 
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4.3 Gráfico de Bode 
 
Gráficos de Bode permitem visualizar a amplitude e a  fase em função da freqüência .  
 
Todas as análise AC assumem que estamos trabalhando com um circuito linear : se 
a saída é 3 V para 1 V da fonte , para uma saída de 30 V teremos 10 V na fonte . 
Ou seja , não há consideração quanto as limitações físicas dos componentes  pois o 
que é simulado são situações algébricas . Para ser analisadas do ponto de vista real 
, podemos então simular a análise com amplitude 1 o que permite que analisemos o 
circuito obtendo assim o valor de seu ganho . 
 
Vamos utilizar o  circuito abaixo : (VAC , R , C , EGND , BUBBLE ) 
 

 
 
Este circuito é um Filtro Passa Baixas , em alta freqüência o capacitor se comporta 
como um curto , permitindo portanto a passagem somente de baixas freqüências .  

Pela equação Hz159
C.R

1
==ω  , temos a freqüência onde teremos a queda de -3 dB do 

circuito . 
 

Vamos agora ao menu Analysis > Setup  , pressione o botão AC Sweep . 
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A seguinte tela se abrirá : 

 

 
 
Vamos realizar a análise de 1 à 10 kHz com 20 pontos por década . 
À seguir clique em OK . 
 
Vamos rodar agora a simulação do programa , pressione o botão Simulate . 

 

 
 
 

Selecione no Menu Trace > Add Trace 
 

 
 
Selecione a tensão V(Vo) .  
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Para mostrar Vo em decibéis basta colocar à expressão dB(V(Vo))  e confirme : 
 

 
 
Observe que para ganho 1 temos 0 dB . 
 
Para mostrar a fase de Vo em graus em função da freqüência  basta colocar à 
expressão Vp(Vo)  e confirme : 
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Se quiséssemos o gráfico da corrente I em dB teríamos dB(I(R1)) e para a obtermos o 
gráfico da fase da corrente basta selecionar a variável desejada na forma Ip(variável) . 
 

4.4 Análise do Ganho de um Amplificador 
 
Uma das mais importantes aplicações da análise em freqüência AC Sweep é a resposta 
em freqüência de um amplificador . Se a análise AC Sweep é realizada num circuito 
com um transistor , o ponto de operação DC é calculado e o transistor é visto como uma  
variação de um pequeno sinal ao redor do ponto de operação . Esta análise só pode ser 
utilizada para calcular o ganho de pequenos sinais e resposta em freqüência . Outras 
análises devem ser realizadas na simulação de transitórios  vista em outro capítulo . 
 
Vamos desenhar o circuito abaixo :  
( VDC , R , C , BUBBLE , VAC , EGND , Q2N3904)  

 
 
Vamos obter a análise AC deste amplificador de 1 Hz à 100 MHz com 20 pontos por 
década . 
 

Vamos agora ao menu Analysis > Setup  , pressione o botão AC Sweep . 
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A seguinte tela se abrirá : 
 

 
 
À seguir clique em OK . 
 
Para simular seu amplificador sempre deixe habilitado a opção Bias Point Detail . 
 
Vamos rodar agora a simulação do programa , pressione o botão Simulate . 

 

 
 

Selecione no Menu Trace > Add Trace 
 

 
 
Selecione a tensão V(Vo) .  
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Para mostrar Vo em decibéis basta colocar à expressão dB(V(Vo))  e confirme : 
 

 

4.5 Ganho do Amplificador Operacional 
 
Neste exemplo vamos utilizar o operacional LM324 . 
Vamos desenhar o circuito abaixo : ( VDC , EGND , R , C , VAC , LM324 , OFFPAGE 
, BUBBLE ) 
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Neste circuito utilizamos um componente chamado OFFPAGE que permite que 
interliguemos partes distantes do circuito que possuam o mesmo Label .  Para definir 
este Label basta darmos um duplo clique sobre o componente OFFPAGE . 
 

 
 
O ganho deste operacional é a relação Vout/Vin . Lembre da recomendação feita no 
item  4.3 . 

Vamos agora ao menu Analysis > Setup  , pressione o botão AC Sweep . 
 

 
 
A seguinte tela se abrirá : 

 
 
Vamos realizar a análise de 1 Hz à 1 MHz com 20 pts/Década . Clique OK e simule . 
 
Pressione o botão Simulate . 
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Selecione no Menu Trace > Add Trace 

 

 
 
Selecione a tensão V(Vo) e confirme : 
 

 
 
O valor obtido é o ganho do operacional na configuração do circuito analisado . 
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4.6 Variação Automática do Ganho do Amplificador Operacional 

4.6.1Análise Paramétrica 
 
 
Neste exemplo vamos utilizar o operacional LM324 . 
Vamos desenhar o circuito abaixo : ( VDC , EGND , R , C , VAC , LM324 , OFFPAGE 
, PARAM, BUBBLE ) 
 

 
Neste circuito utilizamos um componente chamado PARAM que permite possamos 
realizar a análise para diferentes valores do componente parametrizado . 
 
No nosso exemplo , o componente parametrizado é o Rf , ao darmos um duplo clique 
sobre o componente PARAM devemos definir qual o nome do componente 
parametrizado e qual o seu valor padrão . Assim , vamos definir NAME1=RF_Valor e 
VALUE1=1 , isso significa que a análise se somente a análise AC SWEEP for 
realizada , ela será feita para o valor de Rf=1 Ohm .  
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Não podemos esquecer de mudar o valor de Rf para Rf_Valor .  
 

 
 

 
 
O ganho deste operacional é a relação Vout/Vin . Lembre da recomendação feita no 
item  4.3 . 

Vamos agora ao menu Analysis > Setup  , pressione o botão AC Sweep . 
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A seguinte tela se abrirá : 
 

Vamos realizar a análise de 1 Hz à 1 MHz 
com 20 pts/Década . Clique OK para 
confirmar . 
 

 
Vamos agora definir para quais valores de Rf realizaremos a análise . 
 
Vamos agora ao menu Analysis > Setup  , pressione o botão Parametric : 
 

 
 

A seguinte tela se abrirá :                        
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Basta definir as opções como a figura acima . A variável que queremos controlar é um 
parâmetro global de nome Rf_Valor . Queremos que a análise seja feita para uma lista 
de valores (1k 10k 100k 1MEG) . Note que também temos a opção de definir uma faixa 
de valores com o incremento que desejarmos . Após a escolha clique em OK e simule . 
 
Pressione o botão Simulate . 

 

 
 
A seguinte tela se abrirá : 
 

 
 
Um pequeno menu aparece , permitindo que escolhamos para quais valores desejamos 
realizar a análise . Se desejarmos todos basta selecionar >All e à seguir OK . 
 
 
 
Selecione no Menu Trace > Add Trace 
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Selecione a tensão dB(V(Vo)) e confirme : 
 

 
 
Os gráficos obtidos são o ganho do operacional na configuração do circuito analisado . 
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4.7 Indutância Mútua  
 
A indutância mútua requer duas partes : o indutor (L) e o coeficiente de acoplamento 
entre os indutores (K) . Vamos desenhar o circuito abaixo , tomando o cuidado de 
inserirmos os indutores com a marcação de polaridade conforme o desenho : 
 
(VCA , BUBBLE , L , K_LINEAR , C , R , EGND) 
 

 
 
Para definir o acoplamento entre as indutâncias , utilizamos o componente K_Linear . 
Ao clicarmos duas vezes sobre ele , a seguinte tela se abrirá : 
 

 
 

Basta então definir quem é a indutância L1 , L2 , L3 e L4 e qual o coeficiente de 
acoplamento entre elas COUPLING (sendo que ele deve estar compreendido entre -1 e 
1) . 
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Para o primeiro K_Linear definimos L1=L1 , L2=L2 e Coupling=0.4 , para o segundo 
definimos L1=L1,L2=L3 e Coupling=0.8 .  
 
 

Vamos agora ao menu Analysis > Setup  , pressione o botão AC Sweep . 
 

 
 
A seguinte tela se abrirá : 
 

 
 
 
Vamos realizar a análise de 1Hz à 1MHz com 20 pts/Década . Confirme OK e simule . 
 
Pressione o botão Simulate . 
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Selecione no Menu Trace > Add Trace 
 

 
 
Selecione a tensão V(Vo) e confirme : 
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 5 . TRANSIENT (Análise Transitória) 
 
A análise Transitória permite visualizarmos formas de onda em função do tempo assim 
como um osciloscópio . 
 

5.1 Circuito com capacitor com condições iniciais  
 
Vamos desenhar o circuito abaixo : 
 
Componentes ( BUBBLE , R, C, EGND , Sw_tClose )  
 

 
 
Queremos que o capacitor esteja carregado inicialmente com 5 V e que a chave abra em 
t=1 ms . 
 
Inicialmente vamos definir os atributos do capacitor .Ao clicarmos duas vezes sobre o 
capacitor a seguinte tela se abrirá : 
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Os atributos são : 
 
VALUE  : valor do capacitor em Farads . 
IC   : valor da tensão inicial do capacitor em Volts 
 
No nosso caso , VALUE=1U e IC=-5 . 
 
O valor de IC é negativo pois queremos que a tensão sobre o resistor seja positiva . 
Valores negativos de IC fazem com que a tensão siga a convenção de bipolo gerador . 
 
Para definir o tempo de abertura da chave basta clicar duas vezes sobre o nome tClose e 
a seguinte tela se abrirá : 
 

 
 
Defina o tempo de 1ms e clique em Ok para sair . 
 
Estamos utilizando uma chave inicialmente aberta que após um certo tempo fechará , 
componente Sw_tClose . 
Se quiséssemos uma chave inicialmente fechada que após um certo tempo abrisse 
deveríamos utilizar o componenete Sw_tOpen . 
 

Vamos agora ao menu Analysis > Setup  , pressione o botão Transient . 
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A seguinte tela se abrirá : 
 

 
 
 
Vamos realizar a análise com Print Step 1ms , Final Time 6 ms e Step Celling 5ms/500.  
 
O Print Step é utilizado para imprimir o texto no arquivo de saída . A cada Print Step 
segundos os valores serão gravados no arquivo de saída . Se este valor for muito 
pequeno podemos afetar o tempo de simulação deixando-o muito lento .  
 
Final Time define o tempo total da simulação . A simulação será executada de 0 até 
Final Time segundos .  
 
O campo No-Print Delay permite definir após qual intervalo queremos no arquivo de 
saída os resultados da simulação , assim se vamos simular até 1 segundo e nos interessa 
apenas os valores entre 990 ms e 1s , basta setarmos o No-Print Delay para 990 ms . Se 
não desejamos um intervalo específico podemos deixá-lo em branco . Esse parâmetro é 
utilizado para diminuir o tempo de simulação em análises longas . 
 

CUIDADO COM O TEMPO DE SIMULAÇÃO ENTRE OS PONTOS 
(STEP CELLING ) 

 
O Step Celling define o tempo máximo entre os pontos que serão simulados . Quanto 
menor mais preciso será o meu gráfico , no entanto mais tempo levará a minha 
simulação . Se deixado em branco o PSpice calculará um tempo de modo que a 
simulação ocorra no menor tempo possível mantendo o erro dentro de um limite 
máximo . No nosso caso teremos 500 pontos na simulação pois Step Celling = 5ms/500 
. 
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Podemos definir ainda que não queremos as condições inicias durante a simulação , para 
isso basta setarmos a opção Skip Initial Transient Solution , no nosso caso queremos 
que a simulação ocorra com os valores iniciais , vamos assim deixá-lo em branco . 
 
Como vamos simular um circuito onde queremos que as condições iniciais sejam 
calculadas pelo simulador durante a análise transitória devemos desabilitar a opção 
Bias Point Detail . 
 

 
 
Feche a tela e simule . 
 
Pressione o botão Simulate . 
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Selecione no Menu Trace > Add Trace 
 

 
 
Selecione a tensão V(Vr) e confirme : 
 

 
 
Selecione a tensão V(Vc) e confirme : 
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EXERCÍCIOS 
 
1) Ache a tensão Vo . 
 

 
Componentes ( VDC , R , C, EGND , BUBBLE ) 
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2) Ache Vo . 
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3) Ache Vo . 
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5.2 Resposta Transitória do Indutor 
 
Vamos desenhar o circuito abaixo : 
 
Componentes ( BUBBLE , R, L, EGND , Sw_tClose )  
 

 
 
Queremos que o indutor esteja descarregado inicialmente , assim IC=0 e que a chave 
abra em t=0 ms . 
 
Inicialmente vamos definir os atributos do indutor .Ao clicarmos duas vezes sobre o 
indutor a seguinte tela se abrirá : 
 

 
 

Os atributos são : 
 
VALUE  : valor do indutor em Henry . 
IC   : valor da corrente inicial do indutor em Ampere 
 
No nosso caso , VALUE=10mH e IC=0 . 
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O valor de IC pode ser positivo ou negativo dependendo do sentido que queremos a 
corrente inicialmente carregada no indutor . 
 
Para definir o tempo de abertura da chave basta clicar duas vezes sobre o nome tClose e 
a seguinte tela se abrirá : 

 
 
Defina o tempo de 0ms e clique em Ok para sair . 
 
Estamos utilizando uma chave inicialmente aberta que após um certo tempo fechará , 
componente Sw_tClose . 
 

Vamos agora ao menu Analysis > Setup  , pressione o botão Transient . 
 

 
 
A seguinte tela se abrirá : 
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Vamos realizar a análise com Print Step 1ms , Final Time 10 ms . 
 
O Print Step é utilizado para imprimir o texto no arquivo de saída . A cada Print Step 
segundos os valores serão gravados no arquivo de saída . Se este valor for muito 
pequeno podemos afetar o tempo de simulação deixando-o muito lento .  
 
Final Time define o tempo total da simulação . A simulação será executada de 0 até 
Final Time segundos .  
 
Como vamos simular um circuito onde queremos que as condições iniciais sejam 
calculadas pelo simulador durante a análise transitória devemos desabilitar a opção 
Bias Point Detail . 
 

 
 
Feche a tela e simule . 
 
Pressione o botão Simulate . 

 

 
 
Selecione no Menu Trace > Add Trace 
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Selecione a corrente I(IL) e confirme : 
 
 

 
 

5.3 Circuito Grampeador com Zener 
 
Vamos desenhar o circuito abaixo : 
 

 
Componentes : ( VPWL , R , BUBBLE , EGND , D1N750 (Zener)) 

 
O componente VPWL é um tipo de fonte de tensão onde podemos construir segundo a 
nossa vontade a forma de onda que quisermos desde que ela seja feita por linhas retas . 
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Clicando duas vezes sobre o componente VPWL teremos : 
 

 
 

Os atributos DC  e AC são para as análises DC e AC respectivamente , como estamos 
interessados na análise transitória eles podem ser deixados de lado .  
 
A curva é construída de maneira bem simples : no tempo T1 teremos a tensão V1 , no 
tempo T2 teremos a tensão V2 e assim por diante .  
 
Nós vamos construir uma fonte com uma onda triangular de amplitude +-15 V 
conforme a tabela abaixo : 
 

T1 T2 T3 T4 
0 1m 3m 4m 

V1 V2 V3 V4 
0 15 -15 0 

 

 
 
Após definir os parâmetros do componente , clique ok para confirmar . 
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Vamos agora ao menu Analysis > Setup  , pressione o botão Transient . 
 

 
 
A seguinte tela se abrirá : 
 

 

Vamos definir o passo de 1ms 
Tempo final de 4 ms e intervalo entre os 

pontos de 0.01 ms 

 
 

Feche a tela e simule . 
 
Pressione o botão Simulate . 
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Selecione no Menu Trace > Add Trace 

 

 
 
Selecione a tensão V(Vin) e confirme : 
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À seguir selecione V(Vo) e confirme : 
 

 
 

5.4 Análise de Fourier na Tela Gráfica 
 
Vamos desenhar como demonstração o circuito à seguir : 
 

 
 

Componentes ( VSIN , EGND , R , BUBBLE ) 
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Vamos definir a amplitude e a frequência dos geradores de tensão senoidal , para isso 
basta dar um duplo clique sobre eles : 
 

 
 

Definimos VOFF=0 (offset ), VAMPL=10 (amplitude) e FREQ=60 (Frequência do 
sinal em Hz) para o 1º gerador e VOFF=0 (offset ), VAMPL=5 (amplitude) e 
FREQ=180 (3º Harmônica) . 
 

Vamos agora ao menu Analysis > Setup  , pressione o botão Transient . 
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A seguinte tela se abrirá : 
 

 

Vamos definir o passo de 0.1ms 
Tempo final de 20 ms e intervalo entre os 

pontos de 0.001 ms 

 
Feche a tela e simule . 
 
Pressione o botão Simulate . 
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A seguinte tela se abrirá : 

 
 
Selecione no Menu Trace > Add Trace 
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Selecione a tensão V(Vin) e confirme : 
 

 
 
Para observar o espectro do sinal basta clicar sobre o botão FFT ou no menu Trace > 
Fourier : 
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Teremos então o gráfico com o espectro do sinal plotado : 
 

 
 
Para melhor visualização , alteramos a escala das freqüências no eixo x , para isso vá ao 
menu Plot > Axis Settings  , defina a faixa desejada e clique em Ok : 
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5.5 Análise de Fourier com PSpice  
 
As amplitudes e as freqüências componentes de um sinal podem ser obtidas através da 
análise transitória de um sinal . 
 
Como exemplo vamos desenhar o circuito à seguir : 
 

 
Componentes ( VPULSE , EGND , R , BUBBLE) 
 
O VPULSE é uma fonte de tensão pulsada ( pode ser utilizada para criar uma onda 
quadrada ) , para ajustar seus parâmetros , vamos clicar duas vezes sobre ele : 
 

 
 
Parâmetros do VPULSE : 
 

• Período (PER)  : definimos o período da forma de onda em segundos  
• Tempo de subida (TR): definimos o tempo de subida do sinal  
• Tempo de descida (TF) : definimos o tempo de descida do sinal  
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• Tamanho do pulso (PW)  : definimos o tamanho do pulso , este deve ser 
menor que o período definido . Para obtermos uma onda quadrada , PW=PER/2 . 

• Tensão inicial (V1)  : valor inicial da amplitude da tensão do pulso 
• Tensão do pulso (V2)  : valor final da amplitude da tensão do pulso  
• Tempo de espera (TD) : no começo da análise , a fonte de tensão começa com a 

tensão inicial (V1) por um tempo igual ao tempo de espera (delay time) . Depois 
deste tempo a tensão muda do valor inicial para a tensão (V2) . 

 
O pulso terá uma amplitude definida pela faixa de V1 à V2 . 
 
No nosso caso , queremos uma onda quadrada de +- 5V , 1 KHz , assim : 
 
TR=TF= 1 Us ; PER= 2ms ; PW=1 ms ; V1=+5 ; V2=-5 ; TD=0 
 
Após o ajuste dos parâmetros clique OK para sair . 
 
 
É importante lembrar que tempo de subida e descida não devem ser totalmente  
zerados pois podem vir a ocasionar erros de convergência em circuitos mais 
complexos . 
 
 
 
Obs .: Como estamos realizando a análise transitória os parâmetros DC e AC ficam 
em branco , não sendo necessário definí-los .  
 
Vamos agora ao menu Analysis > Setup  , pressione o botão Transient . 
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A seguinte tela se abrirá : 
 

 

Vamos definir o passo de 0.1ms 
Tempo final de 20 ms e intervalo entre os 

pontos de 0.001 ms 
 
 

Como queremos a análise de Fourier de 
um determinado sinal , vamos habilitar a 

análise (Enable Fourier) . 
 

Definimos a frequência central como a 
freqüência da nossa fundamental , no 

nosso caso 1kHz . 
 

À seguir definimos o nº de harmônicas 
que queremos analisar e de quais variáveis 

queremos realizar a análise  . 

 
 

Feche a tela e simule . 
 
Pressione o botão Simulate . 
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A seguinte tela se abrirá : 

 
 
Selecione no Menu Trace > Add Trace 
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Selecione a tensão V(Vin) e confirme : 
 

 
 
Para visualizar o arquivo de saída que contém a análise de Fourier das variáveis , 
pressione o botão ao lado : 
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**** 04/27/03 18:25:16 *********** Evaluation PSpice (Nov 1999) ************** 
 * D:\Doc\Rodrigo\Apostilas\fourier.sch 
 ****     CIRCUIT DESCRIPTION 
****************************************************************************** 
 
* Schematics Version 9.1 - Web Update 1 
* Sun Apr 27 18:25:16 2003 
* Analysis setup ** 
.tran 0.1ms 20ms 0 0.001m 
.four 1k 9 V([Vin]) I(R_R1) 
 
* From [PSPICE NETLIST] section of PSpiceev.ini: 
.lib "nom.lib" 
 
.INC "fourier.net" 
**** INCLUDING fourier.net **** 
* Schematics Netlist * 
 
R_R1         0 Vin  1k   
V_V1         Vin 0   
+PULSE 5 -5 0 1U 1U 0.001 2ms 
 
**** RESUMING fourier.cir **** 
.INC "fourier.als" 
 
**** INCLUDING fourier.als **** 
* Schematics Aliases * 
 
.ALIASES 
R_R1            R1(1=0 2=Vin ) 
V_V1            V1(+=Vin -=0 ) 
_    _(Vin=Vin) 
.ENDALIASES 
 
**** RESUMING fourier.cir **** 
.probe 
 
.END 
 
**** 04/27/03 18:25:16 *********** Evaluation PSpice (Nov 1999) ************** 
 
 * D:\Doc\Rodrigo\Apostilas\fourier.sch 
 
 
 ****     INITIAL TRANSIENT SOLUTION       TEMPERATURE =   27.000 DEG C 
****************************************************************************** 
 NODE   VOLTAGE     NODE   VOLTAGE     NODE   VOLTAGE     NODE   VOLTAGE 
 (  Vin)    5.0000   
 
    VOLTAGE SOURCE CURRENTS 
    NAME         CURRENT 
    V_V1        -5.000E-03 
    TOTAL POWER DISSIPATION   2.50E-02  WATTS 
 
**** 04/27/03 18:25:16 *********** Evaluation PSpice (Nov 1999) ************** 
 * D:\Doc\Rodrigo\Apostilas\fourier.sch 
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 ****     FOURIER ANALYSIS                 TEMPERATURE =   27.000 DEG C 
****************************************************************************** 
 
 
 
FOURIER COMPONENTS OF TRANSIENT RESPONSE V(Vin) 
DC COMPONENT =   4.900000E+00 
 
 HARMONIC   FREQUENCY    FOURIER    NORMALIZED    PHASE        NORMALIZED 
    NO         (HZ)     COMPONENT    COMPONENT    (DEG)       PHASE (DEG) 
 
     1     1.000E+03    2.000E-01    1.000E+00   -9.000E+01    0.000E+00 
     2     2.000E+03    2.000E-01    1.000E+00   -9.000E+01    9.000E+01 
     3     3.000E+03    2.000E-01    1.000E+00   -9.000E+01    1.800E+02 
     4     4.000E+03    2.000E-01    1.000E+00   -9.000E+01    2.700E+02 
     5     5.000E+03    2.000E-01    1.000E+00   -9.000E+01    3.600E+02 
     6     6.000E+03    2.000E-01    1.000E+00   -9.000E+01    4.500E+02 
     7     7.000E+03    2.000E-01    1.000E+00   -9.000E+01    5.400E+02 
     8     8.000E+03    2.000E-01    1.000E+00   -9.000E+01    6.300E+02 
     9     9.000E+03    2.000E-01    1.000E+00   -9.000E+01    7.200E+02 
 
 
     TOTAL HARMONIC DISTORTION =   2.828427E+02 PERCENT 
 
**** 04/27/03 18:25:16 *********** Evaluation PSpice (Nov 1999) ************** 
 * D:\Doc\Rodrigo\Apostilas\fourier.sch 
 
 ****     FOURIER ANALYSIS                 TEMPERATURE =   27.000 DEG C 
****************************************************************************** 
 
FOURIER COMPONENTS OF TRANSIENT RESPONSE I(R_R1) 
 
 DC COMPONENT =  -4.900000E-03 
 
 HARMONIC   FREQUENCY    FOURIER    NORMALIZED    PHASE        NORMALIZED 
    NO         (HZ)     COMPONENT    COMPONENT    (DEG)       PHASE (DEG) 
 
     1     1.000E+03    2.000E-04    1.000E+00    9.000E+01    0.000E+00 
     2     2.000E+03    2.000E-04    1.000E+00    9.000E+01   -9.000E+01 
     3     3.000E+03    2.000E-04    1.000E+00    9.000E+01   -1.800E+02 
     4     4.000E+03    2.000E-04    1.000E+00    9.000E+01   -2.700E+02 
     5     5.000E+03    2.000E-04    1.000E+00    9.000E+01   -3.600E+02 
     6     6.000E+03    2.000E-04    1.000E+00    9.000E+01   -4.500E+02 
     7     7.000E+03    2.000E-04    1.000E+00    9.000E+01   -5.400E+02 
     8     8.000E+03    2.000E-04    1.000E+00    9.000E+01   -6.300E+02 
     9     9.000E+03    2.000E-04    1.000E+00    9.000E+01   -7.200E+02 
 
     TOTAL HARMONIC DISTORTION =   2.828427E+02 PERCENT 
 
          JOB CONCLUDED 
          TOTAL JOB TIME            2.56 
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 5.6 Integrador com Amplificador Operacional Ideal  
 
Vamos desenhar o circuito à seguir : 
 

 
 
Componentes ( OPAMP , EGND , VPULSE , R , C , BUBBLE ) 
 
Neste circuito estamos utilizando um amplificador operacional ideal , este componente 
deve somente ser utilizado para fins de simulação . Seu comportamento não 
corresponde totalmente à realidade quando da montagem de um protótipo . Ele é muito 
útil devido à limitação do número de amplificadores reais que podem ser utilizados na 
versão estudante do PSpice , já que ele não apresenta restrições quando ao número de 
seu uso . 
 
Vamos definir os parâmetros do VPULSE (Secção 5.4) :  
 
No nosso caso , queremos uma onda quadrada de +- 10V , 1 KHz , assim : 

 
TR=TF= 1 Us ; PER= 1ms ; PW=0.5 ms ; V1=+10 ; V2=-10 ; TD=0 

 
Após o ajuste dos parâmetros clique OK para sair . 
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Podemos definir também os parâmetros do operacional , como ganho (GAIN) e tensão 
de alimentação (VPOS/VNEG) : 
 

 
 
 
Ao definirmos os valores de alimentação do operacional ideal estamos também 
definindo seus valores de saturação (limite máximo e mínimo de tensão de saída ) . 
 

Vamos agora ao menu Analysis > Setup  , pressione o botão Transient . 
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A seguinte tela se abrirá : 
 

 

Vamos definir o passo de 20 ns 
Tempo final de 10 ms  

 
A simulação deve demorar um pouco , se 
desejar uma simulação mais rápida altere 

o Print Step 
 
 

 
 

Feche a tela e simule . 
 
Pressione o botão Simulate . 
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Selecione no Menu Trace > Add Trace 
 

 
 
Selecione a tensão V(Vin) e V(Vo) e confirme : 
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6. Digital Simulations ( Simulação com Circuitos Digitais ) 
 
O PSpice pode simular circuitos puramente analógicos , puramente digitais ou uma 
associação de ambos . Na versão do estudante temos limitações quanto ao número de 
componentes e nós que podemos simular o que não permite que utilizemos circuitos 
muito complexos . Os circuitos digitais podem ser analisados sob qualquer tipo de 
simulação que já estudamos , mas geralmente nos interessamos mais pela análise 
transitória onde podemos observar o sinal da saída dos pinos em um determinado 
intervalo de tempo . Por isso vamos demonstrar a utilização dos circuitos digitais com 
ênfase na análise transitória (secção 5) . 
 

6.1 Alimentação dos Sinais Digitais  
 
Apesar de termos que utilizar fontes analógicas para alimentar nossos circuitos digitais  
o PSpice  faz internamente a conversão Analógico-Digital afim de providenciar um 
sinal digital para os componentes digitais . Essas conversões são realizadas por 
pequenos circuitos mas que farão que a simulação fique mais longa e que o limite de 
uso da versão estudante seja logo alcançado . Por isso vamos nos dedicar a conhecer 
fontes de alimentação digitais . 

6.11 Fontes de Sinais Digitais  
 
A fonte STIM nos permite definir qualquer seqüência de bits no tempo . 

 
 
Ao clicarmos duas vezes sobre ela a seguinte tela se abrirá : 
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Ela nos permite definir os tempos e as amplitudes de nosso sinal , como se definíssemos 
a carta de tempos daquele sinal . 
 
No nosso exemplo temos : 

 
TEMPO ABSOLUTO 

 

 
 
Ou seja , do tempo 0 até 1 ms teremos nível 0 , de 1m até 3ms nível 1 , de 3ms à 4 ms 
nível 0 e de 4ms em diante nível 1 .  
 

Vamos agora ao menu Analysis > Setup  , pressione o botão Transient . 
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A seguinte tela se abrirá : 
 

 

Vamos definir o passo de 10 Us 
Tempo final de 10 ms  

 
 
 

 
 

Feche a tela e simule . 
 
Pressione o botão Simulate . 
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A seguinte tela se abrirá : 

 
 
Selecione no Menu Trace > Add Trace 

 

 
 

Copyright  2003 - PSpice – Guia passo-à-passo -      96 



 

Selecione a tensão V(Vsinal) e confirme : 
 
 

 
 
 
TEMPO RELATIVO 
 

 
 
Ao configurarmos como tempo relativo , teremos os tempos sendo definimos à partir do 
último instante . Vamos definir a mesma forma de onda do exemplo anterior utilizando  
tempo relativo . O sinal permanece em zero no instante inicial até 1 ms , mudando para 
o nível 1 , permanece lá por 2ms e muda para o nível 0 , permanece por 2ms e muda 
para o nível 1 onde fica pelo restante do tempo . 
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Procedemos da mesma forma para plotar o sinal de V(Vsinal) . 
 

 
 

 

 
 
REPETIÇÃO DE LOOPS  
 
Como muitos sinais são periódicos um comando chamado GOTO é utilizado para 
termos o looping do sinal . 
Vamos demonstrá-lo produzindo um sinal de clock de 1kHz por quatro pulsos de clock 
e um sinal de 500 Hz por seis pulsos de clock : 
 
Vamos definir os parâmetros da seguinte maneira : 
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Como não é possível demonstrar todos os parâmetros em uma única imagem vamos 
continuar sua edição em outra imagem : 
 

 
 

Vamos agora ao menu Analysis > Setup  , pressione o botão Transient . 
 
A seguinte tela se abrirá : 
 

 

Vamos definir o passo de 10 Us 
Tempo final de 20 ms  

 
 
 

 

Feche a tela e simule .Pressione o botão Simulate .  
 

Copyright  2003 - PSpice – Guia passo-à-passo -      99 



 

A tela do Probe (Gráfica) se abrirá , selecione no Menu Trace > Add Trace 
 

 
 
Selecione a tensão V(Vsinal) e confirme : 
 

 
 

 
 
Se desejarmos que um loop de um pulso se repita indefinidamente use “-1” para o 
número de vezes que o loop deve ser repetido : 
 
COMMAND9 = +1ms GOTO LOOP2 -1 TIMES 
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6.1.2 Digital Clock  (Clock Digital) 
 
Se quisermos utilizar um clock com uma freqüência constante , um componente 
chamado DigClock é utilizado : 
 

 
 
Este componente nada mais é do que um caso particular do componente STIM visto na 
secção anterior . 
Ao clicarmos duas vezes sobre ela a seguinte tela se abrirá : 
 

 
 

Os atributos são : 
 
DELAY  : define o tempo de espera do sinal em zero até começarem os pulsos 
ONTIME : define o tempo em  que o sinal ficará em nível alto (1) 
OFFTIME : define o tempo em que o sinal  ficará em nível baixo (0) 
STARVAL : se 0 permite o funcionamento do clock , se 1 desabilita o clock e o deixa 

em nível alto  
OPPVAL : se 1 permite o funcionamento do clock , se 0 desabilita o clock e o deixa 

em nível baixo  
 
No nosso exemplo , queremos um sinal de 1kHz com tempo de espera de 0.5 ms , 
definimos : DELAY= 0.5ms ; ONTIME = 0.5 ms ; OFFTIME =0.5 ms ; STARVAL=0 
e OPPVAL=1 . Clique ok para confirmar e sair .  
 
Observe que a onda não necessariamente tem que ser quadrada podendo assumir 
também a forma retangular . 
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Vamos agora ao menu Analysis > Setup  , pressione o botão Transient . 
 

 
 
A seguinte tela se abrirá : 
 

 

Vamos definir o passo de 10 Us 
Tempo final de 20 ms  

 
 
 

 
Feche a tela e simule . 
Pressione o botão Simulate . 
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A tela do Probe (Gráfica) se abrirá , selecione no Menu Trace > Add Trace 
 

 
 
Selecione a tensão V(Vsinal) e confirme : 
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6.2 Utilizando ao mesmo tempo componentes analógicos e digitais  
 
Vamos desenhar o circuito abaixo de um amplificador operacional que proporciona o 
clock de um flip-flop J-K : 
 
 

 
 
 
Componentes ( VPULSE ; BUBBLE ; EGND ; STIM1 ; OPAMP , R , D1N750 ; 7414 ; 
74107 ; HI ) 
 
 
Todos os circuitos seqüenciais lógicos que possuem a função clear devem 
ter seus estados lógicos iniciais definidos antes de simularmos o circuito . 
 
 
Se não definirmos o estado inicial dos circuitos seqüenciais lógicos o PSpice não saberá 
qual estado inicial deve ser simulado , como o estado inicial é indefinido ele não poderá 
simular os estados seguintes .  
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O sinal digital está configurado da seguinte maneira : 
 

 
 
O clear do flip-flop terá o estado inicial nulo no tempo definido entre 0 e 20 us , 
permanecendo em nível lógico 1 após este tempo . 
 
A tensão pulsada  VPULSE será definida como uma onda quadrada de 1kHz com 
tensões entre -1 e 1 V : 

 
O amplificador operacional tem um ganho definido pelos resistores  de 10 vezes e 
produz uma tensão quadrada de +- 10V em 1kHz no bubble Vo . 
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A forma de onda será ceifada por um diodo zener que limita a tensão no bubble Vo1 . 
 
Esta tensão é compatível com o nível TTL do 7414 . A saída do Schimit-Trigger  deve 
ser uma onda quadrada de 0 à 5 V com freqüência de 1 kHz (Vo2) .  
 
O flip-flop está funcionando como um divisor por 2 (as entradas (J=K=1) são definidas 
por um componente chamado HI que insere um nível lógico alto nas entradas ) , assim 
as saídas Q e Qbarrado  devem estar com freqüência de 500 Hz e defasadas de 180º . 
 
Se quisessemos um nível lógico baixo podemos utilizar o componente LO . 
 

 
Vamos agora ao menu Analysis > Setup  , pressione o botão Transient . 
 
A seguinte tela se abrirá : 
 

 

Vamos definir o passo de 1ms 
Tempo final de 15 ms  

 
 
 

 
Feche a tela e simule . 
Pressione o botão Simulate . 
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A tela do Probe (Gráfica) se abrirá , selecione no Menu Trace > Add Trace 

 

 
 
Selecione a tensão V(Vo) , Vo2 , Q e Qbarrado e confirme : 
 
 

 
 
Os sinais digitais são dispostos em um gráfico separado dos sinais analógicos , mas 
ambos dividem a mesma escala de tempos . 
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6.2.1 Contador  
 
Vamos simular o circuito de um contador : 
 
O 74393 é um contador binário de 0 à 15 : 
 
------------------------- 
CLR  CLK  |  Qd Qc Qb Qa 
-------------------------- 
 1          X    |  0     0    0    0 
 0        POS |    Count 
 0        POS |    Count 

 
 
As configurações do operacional , do VPULSE e da análise transitória seguem os 
mesmos valores do item anterior 6.2 , sendo que a única mudança foi no sinal digital 
STIM : 
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Observe que nos esquemas , não aparecem os pinos de alimentação das portas 
lógicas , pois o PSpice providencia um circuito para sua alimentação  mas não o 
mostra afim de não tumultuar a visualização dos circuitos na tela .  
 
Em muitos casos temos pinos de componentes que não serão utilizados , o PSpice 
necessita que todos os pinos estejam conectados , assim , para pinos que não serão 
utilizados , basta conectá-los ao componente NC (not connected ) . 
 
Vamos fazer um outro exemplo : 
 
Contador Binário com o 7393 : 
 
RO1  RO2  |  Qd Qc Qb Qa 
-------------------------- 
  1       1      |  0     0    0    0 
  0      X      |    Count 
  X      0      |    Count 
 
As configurações do operacional , do VPULSE e da análise transitória seguem os 
mesmos valores do item anterior 6.2.1 . 
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Observe que este componente (7493) não possui Clear ou Preset , mas temos que definir 
qual o estado inicial dos seus flip-flops internos . 
 

Vamos agora ao menu Analysis > Setup  , pressione o botão Digital Setup : 
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A seguinte tela se abrirá : 
 
 

 
 
Nela podemos definir qual o estado inicial dos flip-flops ([All 0] Todos 0 ; [All 1] 
Todos 1 ; [All X] Indefinido) . 
 
Depois é só simular normalmente assim como nos casos anteriores . 
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6.3 Observações 
 
Quando inserirmos um componente digital temos que tomar um certo cuidado . Vamos 
exemplificar inserindo um componente 7400 : 
 

 
 
Ao inserirmos novamente o mesmo componente o PSpice mantém a mesma pinagem 
mudando a numeração como se fosse um novo componente : 
 
 
como queremos que seja utilizado ainda o mesmo circuito integrado visto que o mesmo 
possui 4 portas lógicas internas vamos renomear a porta lógica dando um duplo clique 
sobre sua referência U1A (figura1) : 
  

 
figura 1 

 
 
figura 2 figura 3 

 
 
Agora basta mantermos a mesma referência mudando U2 para U1 e alterando o Gate 
(pinos ) para B (figura 2) , assim teremos a numeração do segundo conjunto de pinos do 
CI (figura 3) e assim por diante se quisermos outras portas lógicas basta alterar para C e 
D . 
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7. Monte Carlo Analyses ( Análise do Pior Caso ) 
 
As análises Monte Carlo são utilizadas para observar como as tolerâncias dos 
componentes podem afetar o desempenho do circuito . A análise do pior caso é utilizada 
para encontrar os valores máximos e mínimos de um parâmetro dada as tolerâncias dos 
componentes . A análise do pior caso demonstra estatisticamente qual a probabilidade 
de uma dada situação .  
A análise somente pode ser executada quando temos fontes cujos parâmetros são 
variáveis em amplitude ou freqüência ( DC Sweep / AC Sweep / Transient ) .  

7.1 Análise do Pior no Divisor de Tensão 
 
Vamos utilizar como exemplo um divisor de tensão como o desenho abaixo : 
 
Componentes ( VDC , BUBBLE , R , EGND ) 
 

 
 
Para definirmos a tolerância absoluta dos resistores , basta dar um duplo clique sobre 
cada um deles . A seguinte tela se abrirá : 
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No parâmetro tolerância , definimos a percentagem de variação do valor total do 
resistor . Clique OK para sair . 
 
Muitos dos componentes do PSpice já possui o campo TOLERANCE para ser 
preenchido . 
 
No menu Analyses > Setup definimos as condições da variação e qual variável será 
análise no menu Monte Carlo/Worst Case :  
 

 
 
 

Nós queremos determinar qual o pior caso para o ganho máximo , desde que o ganho é 
dado por Vo/Vin e Vin varia de 10 V à 20 V com incremento de 1 V de amplitude , a 
amplitude do ganho é exatamente o valor de Vo/Vin . 
 
A análise será do pior caso (Worst Case) . A análise será feita em DC porque queremos 
determinar qual o ganho em DC do circuito . A variável de saída (output var)  que 
queremos monitorar é a tensão V(Vo) . Como queremos à máxima variação escolhemos 
MAX .  
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Vamos definir a variação da fonte VDC : 
 

 
 

Feche a tela e simule . 
Pressione o botão Simulate . 
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A tela do Probe (Gráfica) se abrirá , onde podemos escolher qual as características das 
variações queremos plotar (nominal [MINAL]  e pior caso [L DEVICES]) , no nosso 
caso são todas (All) . Clique ok para sair . 
 

 
 
selecione no Menu Trace > Add Trace 

 

 
 
Selecione a tensão V(Vo) e confirme : 
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Temos o gráfico da tensão Vo com os valores nominais dos resistores e também no pior 
caso de máxima variação . 
 
Para obtermos o gráfico da variação do ganho , no menu Trace > Add Trace defina a 
equação V(Vo)/V(Vin) e teremos o gráfico do ganho nominal e máximo do circuito : 
 

 
 

Vamos calcular manualmente o ganho e verificar à solução simulada : 
 

Vo/Vin = R2/(R1+R2) 
 

Sendo R2= 1000 Ω e R1=1000 Ω -   O Ganho Nominal é :                     Vo/Vin = 0.5 
Sendo R2= 1050 Ω e R1=950   Ω -   O Ganho Máximo do pior caso é : Vo/Vin = 0.525 
Sendo R2= 950 Ω   e R1=1050 Ω -   O Ganho Mínimo do pior caso é  : Vo/Vin = 0.475 
 
Vemos que o resultado simulado correspondeu ao esperado . 
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7.2 Análise Monte Carlo do  Divisor de Tensão 
 
A análise Monte Carlo é utilizada para responder à questão : Que percentagem do meu 
circuito atingirá ou não minhas especificações ? . Analisando pelo pior caso podemos 
verificar quais os valores máximos e mínimos do meu parâmetro analisado , vemos 
assim se o circuito como um todo atende nossa especificação . Se isto não ocorrer 
podemos utilizar a análise Monte Carlo para estimar que percentagem do circuito será 
aceitável . 
 
Um exemplo é o ganho do divisor de tensão  , no caso anterior vimos que o ganho ficou 
entre 0.475 e 0.525 , mas se nossa especificação mínima fosse 0.49 , que percentagem 
do circuito atenderia nossa especificação . Isso é o descobriremos . 
 
 
Vamos utilizar o mesmo circuito anterior modificando a fonte DC por uma AC  (VAC) : 
 

 
 

No menu Analyses > Setup definimos as condições da variação e qual variável será 
análise no menu Monte Carlo/Worst Case :  
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Vamos definir a variação da fonte VAC em 1 V numa freqüência fixa em 1 kHz : 
 

 
 

O ganho não muda em nada , o fato de utilizarmos uma AC é que podemos fixar a 
amplitude já que queremos saber a variação do ganho .  

 
 

A análise será de Monte Carlo .  O número de vezes que o análise será efetuada será de 
100 (MC Runs 100) . Para cada vez , cada parte que possui uma tolerância terá um 
valor aleatório escolhido dentro de sua faixa de tolerância . A análise será feita em DC 
porque queremos determinar qual o ganho em DC do circuito . A variável de saída 
(output var)  que queremos monitorar é a tensão V(Vo) . Vamos escolher YMAX pois 
queremos a resposta da saída  ordenada do maior para à menor diferença do valor 
nominal .  YMAX define a função : 
 
f =│V(Vo)- 0.5 │    onde 0.5 é o valor nominal do ganho  
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Quanto à MC Outputs vamos escolher All pois  queremos os valores intermediários da 
saída para cada tentativa . Clique OK para sair  
 
Pressione o botão Simulate . 

 

 
 
A tela do Probe (Gráfica) se abrirá , selecione All ,selecione no Menu Trace > Add 
Trace 

 

 
 
Selecione a tensão V(Vo) e confirme : 
 
e teremos o Histograma com as percentagens de amostras em função dos valores do 
ganho : 
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: 
 
Os desvios são dados em relação ao valor nominal : 
 
Nossa especificação mínima para o ganho era de 0.49 , assim como temos 40 amostras 
(havíamos definido 100 amostras mas a versão estudante tem um limite 
máximo de 40 ) basta verificar quantas delas não atendem , ou seja , estão 
localizadas abaixo de 0.49 . No nosso caso temos cerca de 18 % .Este número 
representa a quantidade de circuitos que não passarão na especificação mínima à cada 
40 unidades . Quanto maior o número de amostras mais precisão teremos . 
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